BadObjectId Property (ActiveX/CSP)

Specifies the object ID of the object whose properties do not match those defined in the drawing standards file being compared against.

Supported platforms: Windows only

Namespace: AcStMgr

Assembly: AcStMgr.tlb

Signature

VB.NET:

object.BadObjectId

C#:

object.BadObjectId;
object

Type: AcStError object

The object this property applies to.

Property Value

Read-only: No

Type: LongPtr (Long)

The object ID of the object associated with the error.

Remarks

No additional remarks.

Release Information

Releases: AutoCAD 2004 and later

Examples

VB.NET:

Public Sub PlugIn_Start(ByVal pStartError As AcStError) _
                        Implements IAcStPlugin2.Start

    ' If pStartError is an object, checking should start
    ' from that error, not the beginning of the current context.
    If IsNothing(pStartError) = False Then

        ' Get the ObjectId of the first object to check
        Dim badId As Long = pStartError.BadObjectId

        ' Find the index for ObjectId in the context list stored in m_objIDArray
        For m_curIndex = 0 To m_ContextList.Count - 1
            If m_ContextList.Item(m_curIndex) = badId Then
                m_curIndex = m_curIndex - 1
                PlugIn_Next()
            End If
        Next
    Else
        ' A valid AcStError object was not passed to the method.
        ' Checking should start at the beginning of the context list.
        m_curIndex = -1
        PlugIn_Next()
    End If
End Sub

C#:

public void PlugIn_Start(AcStError pStartError)
{
    // If pStartError is an object, checking should start
    // from that error, not the beginning of the current context.
    if ((pStartError == null) == false)
    {
        // Get the ObjectId of the first object to check
        long badId = pStartError.BadObjectId;

        // Find the index for ObjectId in the context list stored in m_objIDArray
        for (m_curIndex = 0; m_curIndex <= m_ContextList.Count - 1; m_curIndex++)
        {
            if (Convert.ToInt64(m_ContextList.GetItem(m_curIndex)) == badId)
            {
                m_curIndex = m_curIndex - 1;
                PlugIn_Next();
            }
        }
    }
    else
    {
        // A valid AcStError object was not passed to the method.
        // Checking should start at the beginning of the context list.
        m_curIndex = -1;
        PlugIn_Next();
    }
}