BeginFilesGraphCreation Method (ActiveX/ATO)

Triggered when a new node is being added to the files graph of the transmittal set.

Supported platforms: Windows only

Namespace: TRANSMITTALLib

Assembly: AcETransmit19.tlb

Signature

VB.NET:

Friend Class custom_class_name
    Implements TransmittalAddFileNotificationHandler

    Public Sub beginFilesGraphCreation(pTransmit As TRANSMITTALLib.TransmittalOperation) _
        Implements TRANSMITTALLib.ITransmittalAddFileNotificationHandler.beginFilesGraphCreation
        ...
    End Sub

End Class

C#:

internal class custom_class_name : TransmittalAddFileNotificationHandler
{
    public void beginFilesGraphCreation(TRANSMITTALLib.TransmittalOperation pTransmit)
    {
        ...
    }
}
custom_class_name

The name of the custom class.

pTransmit

Access: Input-only

Type: TransmittalOperation object

Pointer to the TransmittalOperation object that represents the transmittal set in which a new node is being added to the files graph.

Return Value (RetVal)

No return value.

Remarks

No additional remarks.

Release Information

Releases: AutoCAD 2004 and later

Examples

VB.NET:

' Custom class used to monitor files being added to the transmittal package
Friend Class MyTransFileNotifier
    Implements TransmittalAddFileNotificationHandler

    Public Sub beginFilesGraphCreation(pTransmit As TRANSMITTALLib.TransmittalOperation) _
        Implements TRANSMITTALLib. _
           ITransmittalAddFileNotificationHandler.beginFilesGraphCreation

        Application.DocumentManager.MdiActiveDocument.Editor. _
            WriteMessage(Environment.NewLine & "File graph being created.")
    End Sub
End Class

C#:

// Custom class used to monitor files being added to the transmittal package
internal class MyTransFileNotifier : TransmittalAddFileNotificationHandler
{
    public void beginFilesGraphCreation(TRANSMITTALLib.TransmittalOperation pTransmit)
    {
        Application.DocumentManager.MdiActiveDocument.Editor.
            WriteMessage(Environment.NewLine + "File graph being created.");
    }
}