Type Property (ActiveX/CAO)

Specifies the data type of the current object.

Signature

VBA / VB.NET

object.Type
object

Type: KeyDescription

The object or objects this property applies to.

Type

Type: CaoDataType enum

The data type of the object. Can be one of the following constants:

  • kCaoTypeText
  • kCaoTypeNumeric
  • kCaoTypeInteger
  • kCaoTypeDouble
  • kCaoTypeDate
  • kCaoTypeTime
  • kCaoTypeTimestamp
  • kCaoTypeBit
  • kCaoTypeBlob