GetLinks Method (ActiveX/CAO)

Gets a Links collection.

Signature

VBA / VB.NET

RetVal = object.GetLinks([LinkTemplate] [, ObjectIDs] [, LinkTypes] [, Document])
object

Type: DbConnect

The object or objects this method applies to.

LinkTemplate

Type: LinkTemplate, or String identifying a link template; input-only; optional

If specified, indicates the link template whose links are returned.

ObjectIDs

Type: Variant (array of Longs); input-only; optional

If specified, each long is the object ID of an AutoCAD entity whose links are to be returned.

LinkTypes

Type: Integer; input-only; optional

Specifies the type of links to return. You can specify any combination of the following link types:

  • kFSLabelType: Freestanding labels
  • kAttachedLabelType: Attached labels

If no value is specified, all label links are returned.

Document

Type: AcadDocument; input-only; optional

This argument is ignored if a LabelTemplate object is passed as the first argument. If this argument is not specified, the document object is identified as follows:

  • If the LabelTemplate argument is a string naming a label template, the current document is used.
  • If the LabelTemplate argument is a LabelTemplate object, the label template document is used.
RetVal

Type: Links

The Links collection for the specified link template.

Remarks

If no arguments are specified, GetLinks returns all entity links associated with the current document.