PreDatabaseProcessing Method (ActiveX/ATO)

Triggered before the processing of a database.

Supported platforms: Windows only

Namespace: TRANSMITTALLib

Assembly: AcETransmit19.tlb

Signature

VB.NET:

Friend Class custom_class_name
    Implements TransmittalDatabaseNotificationHandler

    Public Function preDatabaseProcessing(pDatabase As Object, _
                                          pFile As TransmittalFile, _
                                          pTransmit As TransmittalOperation) _
                                      As Integer _
                 Implements ITransmittalDatabaseNotificationHandler.preDatabaseProcessing
        ...
    End Function

End Class

C#:

internal class custom_class_name : TransmittalDatabaseNotificationHandler
{
     public int preDatabaseProcessing(object pDatabase, 
                                      TransmittalFile pFile,
                                      TransmittalOperation pTransmit)
     {
        ...
        return RetVal;
     }
}
custom_class_name

The name of the custom class.

pDatabase

Access: Input-only

Type: Object

Pointer to the AcadDatabase object that will be processed.

pFile

Access: Input-only

Type: TransmittalFile object

Pointer to the TransmittalFile object that contains information about the drawing file in which the database is stored.

pTransmit

Access: Input-only

Type: TransmittalOperation object

Pointer to the TransmittalOperation object that represents the transmittal set in which the drawing file is contained.

Return Value (RetVal)

Type: Long

Remarks

No additional remarks.

Release Information

Releases: AutoCAD 2005 and later

Examples

VB.NET:

' Custom class used to monitor the processing of a drawing
Friend Class MyTransDbNotifier
    Implements TransmittalDatabaseNotificationHandler

    Public Function preDatabaseProcessing(pDatabase As Object, _
                                          pFile As TRANSMITTALLib.TransmittalFile, _
                                          pTransmit As TRANSMITTALLib.TransmittalOperation) _
                                      As Integer _
                 Implements TRANSMITTALLib. _
                    ITransmittalDatabaseNotificationHandler.preDatabaseProcessing

        Application.DocumentManager.MdiActiveDocument.Editor. _
            WriteMessage(Environment.NewLine & "Database preprocessing: " & pFile.sourcePath)

        Return 1
    End Function
End Class

C#:

// Custom class used to monitor the processing of a drawing
internal class MyTransDbNotifier : TransmittalDatabaseNotificationHandler
{
    public int preDatabaseProcessing(object pDatabase, TRANSMITTALLib.TransmittalFile pFile,
                                        TRANSMITTALLib.TransmittalOperation pTransmit)
    {
        Application.DocumentManager.MdiActiveDocument.Editor.
            WriteMessage(Environment.NewLine + "Database preprocessing: " + pFile.sourcePath);

        return 1;
    }
}