AddFileNotificationHandler Method (ActiveX/ATO)

Triggered when a new file is added to the transmittal set.

Supported platforms: Windows only

Namespace: TRANSMITTALLib

Assembly: AcETransmit19.tlb

Signature

VB.NET:

Friend Class custom_class_name
    Implements TransmittalAddFileNotificationHandler

    Public Sub addFileNotificationHandler(pFile, pTransmit) _
        Implements TRANSMITTALLib.ITransmittalAddFileNotificationHandler.addFileNotificationHandler
        ...
    End Sub

End Class

C#:

internal class custom_class_name : TransmittalAddFileNotificationHandler
{
    public void addFileNotificationHandler(pFile, pTransmit)
    {
        ...
    }
}
custom_class_name

The name of the custom class.

pFile

Access: Input-only

Type: TransmittalFile object

Pointer to the TransmittalFile object created when a drawing or file is added to the transmittal set.

pTransmit

Access: Input-only

Type: TransmittalOperation object

Pointer to the TransmittalOperation object that represents the transmittal set in which a drawing or file is being added.

Return Value (RetVal)

No return value.

Remarks

No additional remarks.

Release Information

Releases: AutoCAD 2004 and later

Examples

VB.NET:

' Custom class used to monitor files being added to the transmittal package
Friend Class MyTransFileNotifier
    Implements TransmittalAddFileNotificationHandler

    ' Used to get a notification when a drawing or file is added to the transmittal package
    Public Sub addFileNotificationHandler(pFile As TRANSMITTALLib.TransmittalFile, _
                                          pTransmit As TRANSMITTALLib.TransmittalOperation) _
            Implements TRANSMITTALLib. _
               ITransmittalAddFileNotificationHandler.addFileNotificationHandler
        Application.DocumentManager.MdiActiveDocument.Editor. _
            WriteMessage(Environment.NewLine & _
                         "File added to transmittal package: " & pFile.sourcePath)
    End Sub
End Class

C#:

// Custom class used to monitor files being added to the transmittal package
internal class MyTransFileNotifier : TransmittalAddFileNotificationHandler
{
    // Used to get a notification when a drawing or file is added to the transmittal package
    public void addFileNotificationHandler(TRANSMITTALLib.TransmittalFile pFile, 
                                           TRANSMITTALLib.TransmittalOperation pTransmit)
    {
        Application.DocumentManager.MdiActiveDocument.Editor.
            WriteMessage(Environment.NewLine + "File added to transmittal package: " +
                         pFile.sourcePath);
    }
}