Password Property (ActiveX)

Specifies the encryption password. (Obsolete)

Supported platforms: Windows only

Signature

VBA:

object.Password
object

Type: SecurityParams

The object this property applies to.

Property Value

Read-only: No

Type: String

The encryption password.

Remarks

Note: Starting with AutoCAD-2016 based products, the ability to password protect a drawing file has been discontinued.

Examples

VBA:

Sub Example_Password()
    ' This example opens a password-protected file, closes it, and then opens another
    ' password-protected file.

    ThisDrawing.Application.Documents.Open "C:\MyDrawing.dwg", , "MYPASSWORD"
    'AutoCAD converts all passwords to uppercase before applying them

    ThisDrawing.Close

    ThisDrawing.Application.Documents.Open "C:\MyDrawing2.dwg", , "MYSECONDPASSWORD"
End Sub

Visual LISP:

Not available