Reset Method (ActiveX/CSP)

Resets the position of the error enumerator used to check a database or resets an object for reuse.

Supported platforms: Windows only

Namespace: AcStMgr

Assembly: AcStMgr.tlb

Signature

VB.NET:

object.Reset()

C#:

object.Reset();
object

Type: AcStError, AcStErrorIterator, AcStFix object

The objects this method applies to.

Return Value (RetVal)

No return value.

Remarks

The Reset method of the AcStErrorIterator object is for internal use only.

Release Information

Releases: AutoCAD 2004 and later

Examples

VB.NET:

Public Sub PlugIn_Clear() Implements IAcStPlugin2.Clear

    ' If the XML Document object exist, the plug-in is being used by the Batch Standards Checker.
    ' Output the standards items that were used for comparison to the Standards Items section.
    If IsNothing(m_xmlDoc) = False Then
        WriteStandardsItemsInfo()
    End If

    ' Clean up the global variables
    m_xmlDoc = Nothing
    m_pPlugin = Nothing
    m_curIndex = -1
    m_RecommendedFixIndex = -1
    m_FixCnt = 0
    m_pManager = Nothing
    m_pDWSDatabase = Nothing
    m_pCheckDatabase = Nothing

    If IsNothing(m_pError) = False Then
        m_pError.Reset()
        m_pError = Nothing
    End If

    ' << Change based on standards implementation >>
    If IsNothing(m_LayerCacheArray) = False Then
        Dim i As Integer
        For i = 0 To UBound(m_LayerCacheArray)
            If IsDBNull(m_LayerCacheArray(i).StandardsFix) = False Then
                m_LayerCacheArray(i).StandardsFix.Reset()
                m_LayerCacheArray(i).StandardsFix = Nothing
            End If
        Next
        Erase m_LayerCacheArray
    End If

    If IsNothing(m_FixArray) = False Then
        Erase m_FixArray
    End If

    m_ContextList.Clear()
End Sub

C#:

public void PlugIn_Clear()
{
    // If the XML Document object exist, the plug-in is being used by the Batch Standards Checker.
    // Output the standards items that were used for comparison to the Standards Items section.
    if ((m_xmlDoc == null) == false)
    {
        WriteStandardsItemsInfo();
    }

    // Clean up the global variables
    m_xmlDoc = null;
    m_pPlugin = null;
    m_curIndex = -1;
    m_RecommendedFixIndex = -1;
    m_FixCnt = 0;
    m_pManager = null;
    m_pDWSDatabase = null;
    m_pCheckDatabase = null;

    if ((m_pError == null) == false)
    {
        m_pError.Reset();
        m_pError = null;
    }

    // << Change based on standards implementation >>
    if ((m_LayerCacheArray == null) == false)
    {
        int i = 0;

        int nLBound = m_LayerCacheArray.GetLowerBound(0);
        int nUBound = m_LayerCacheArray.GetUpperBound(0);

        for (i = 0; i <= nUBound; i++)
        {
            if (m_LayerCacheArray[i].StandardsFix != null)
            {
                m_LayerCacheArray[i].StandardsFix.Reset();
                m_LayerCacheArray[i].StandardsFix = null;
            }
        }
        m_LayerCacheArray = null;
    }

    if ((m_FixArray == null) == false)
    {
        m_FixArray = null;
    }

    m_ContextList.Clear();
}