Open Method (ActiveX/ATO)

Opens a database in memory.

For internal use only.

Supported platforms: Windows only

Namespace: TRANSMITTALLib

Assembly: AcETransmit19.tlb

Signature

VB.NET:

Friend Class custom_class_name
    Implements ITransmittalFileOperationOverride

    Public Sub Open(ByRef fileName As <Unsupported variant type>, attemptToRecover As Long, ByRef ppDb As System.IntPtr) _
        Implements ITransmittalFileOperationOverride.Open

        ...
    End Sub
End Class

C#:

internal class custom_class_name : ITransmittalFileOperationOverride
{
    public void Open(ushort fileName, long attemptToRecover, System.IntPtr ppDb)
    {
        ...
    }
}
custom_class_name

The name of the custom class.

fileName

Access: Input-only

Type: UShort (<Unsupported variant type>)

Name of the drawing file to open in memory.

attemptToRecover

Access: Input-only

Type: Long

  • 0 (False): No attempt to recover the drawing file should be made before opening the file
  • 1 (True): An attempt to recover the drawing file should be made before opening the file
ppDb

Access: Input-only

Type: Any (Pointer)

Pointer to the database object of the drawing file being opened.

Return Value (RetVal)

No return value.

Remarks

This method is for internal use only.

Release Information

Releases: AutoCAD 2009 and later

Examples

VB.NET:

Not available

C#:

Not available