NewErrorIterator Method (ActiveX/CSP)

Creates an iterator for checking errors in a database.

For internal use only.

Supported platforms: Windows only

Namespace: AcStMgr

Assembly: AcStMgr.tlb

Signature

VB.NET:

RetVal = object.NewErrorIterator(pDb, szPathName, pluginProgIdArray, stdNameArray, stdPathArray, stdDbArray)

C#:

RetVal = object.NewErrorIterator(pDb, szPathName, pluginProgIdArray, stdNameArray, stdPathArray, stdDbArray);
object

Type: AcStManager object

The object this method applies to.

pDb

Access: Input-only

Type: AcadDatabase object

The database containing the objects to check.

szPathName

Access: Input-only

Type: String

The name and path to the drawing file that contains the database to check.

pluginProgIdArray

Access: Input-only

Type: Variant (Array of Strings)

The array of ProgIds that represent the plug-ins to validate the standards against in the database.

stdNameArray

Access: Input-only

Type: Variant (Array of Strings)

The array of names for the drawing standards (DWS) files that contain the standards to check against.

stdPathArray

Access: Input-only

Type: Variant (Array of Strings)

The array of paths for the drawing standards (DWS) files that contain the standards to check against.

stdDbArray

Access: Input-only

Type: Variant (Array of AcadDatabase objects)

The array of databases that contain the standards to check against.

Return Value (RetVal)

Type: AcStErrorIterator object

The new error iterator for stepping through the errors in the drawing database.

Remarks

The iterator is created in the context of a set of plug-ins, DWS files, and a drawing to check, which are specified by the input parameters. This context is invariant over the lifetime of the iterator object.

The arrays passed as input parameters are single-dimension arrays of the same length. Individual entries in these arrays can be null.

Release Information

Releases: AutoCAD 2004 and later

Examples

VB.NET:

Not available

C#:

Not available