PreProcessHandling Method (ActiveX/ATO)

Triggered before files in a transmittal set are processed.

For internal use only.

Supported platforms: Windows only

Namespace: TRANSMITTALLib

Assembly: AcETransmit19.tlb

Signature

VB.NET:

Friend Class custom_class_name
    Implements ITransmittalFileOperationOverride

    Public Sub PreProcessHandling(digitalSignedFiles As System.Array, ByRef isCancelled As Integer) _
        Implements ITransmittalFileOperationOverride.PreProcessHandling

        ...
    End Sub
End Class

C#:

internal class custom_class_name : ITransmittalFileOperationOverride
{
    public void PreProcessHandling(System.Array digitalSignedFiles, int isCancelled)
    {
        ...
    }
}
custom_class_name

The name of the custom class.

digitalSignedFiles

Access: Input-only

Type: Unknown (Array of objects)

Array of drawing files in the transmittal set that are digitally signed.

isCancelled

Access: Input-only

Type: Integer

  • 0 (False): Processing should not be cancelled
  • 1 (True): Processing should be cancelled

Return Value (RetVal)

No return value.

Remarks

This method is for internal use only.

Release Information

Releases: AutoCAD 2004 and later

Examples

VB.NET:

Not available

C#:

Not available