GetDbStampArrays Method (ActiveX/CSP)

Gets information about the plug-ins that have a stamped drawing standards (DWS) database.

For internal use only.

Supported platforms: Windows only

Namespace: AcStMgr

Assembly: AcStMgr.tlb

Signature

VB.NET:

object.GetDbStampArrays(pDb, pProgIDArray, pNameArray, pVersionArray, pDescriptionArray, pAuthorArray, pHRefArray)

C#:

object.GetDbStampArrays(pDb, ref pProgIDArray, ref pNameArray, ref pVersionArray, ref pDescriptionArray, ref pAuthorArray, ref pHRefArray);
object

Type: AcStManager object

The object this method applies to.

pDb

Access: Input-only

Type: AcadDatabase object

The drawing standards (DWS) database containing the desired stamp.

pProgIDArray

Access: Input/Output

Type: Variant (Array of Strings)

The array of ProgIds for the plug-ins that have stamped the database.

pNameArray

Access: Input/Output

Type: Variant (Array of Strings)

The array of names (Name property) for the plug-ins that have stamped the database.

pVersionArray

Access: Input/Output

Type: Variant (Array of Strings)

The array of versions (Version property) for the plug-ins that have stamped the database.

pDescriptionArray

Access: Input/Output

Type: Variant (Array of Strings)

The array of descriptions (Description property) for the plug-ins that have stamped the database.

pAuthorArray

Access: Input/Output

Type: Variant (Array of Strings)

The array of authors (Author property) for the plug-ins that have stamped the database.

pHRefArray

Access: Input/Output

Type: Variant (Array of Strings)

The array of URLs (HRef property) for the plug-ins that have stamped the database.

Return Value (RetVal)

No return value.

Remarks

The arrays output by this method all have the same bounds. The elements at a particular index in one array correspond to the elements with the same index in another array. In other words, the elements at a particular index in the different arrays all describe the same plug-in.

Release Information

Releases: AutoCAD 2004 and later

Examples

VB.NET:

Not available

C#:

Not available