FileType Enumeration (ActiveX/ATO)

Indicates a file's type in the transmittal set.

Supported platforms: Windows only

Namespace: TRANSMITTALLib

Assembly: AcETransmit19.tlb

Signature

FileType

Remarks

The enumeration values can be used to identify a file's type after it has been added to a transmittal set. The values represent those returned by the FileType and type properties of a TransmittalFile object.

Members

These members are part of this enumeration:

Name

Description

e3rdPartyAddedFile

File added by third-party application; type is unknown

eAltFontFile

Alternate font file (see FONTALT system variable)

eDataLinkFile

DataLink file

eDGNUnderlay

MicroStation® DGN underlay file

eDGNUnderlayDependent

Dependency of a DGN underlay file

eDWFUnderlay

DWF underlay file

eDwgFile

Drawing file

eDwsFile

Drawing standards file

eFontFile

Font file

eFontMapFile

Font map (FMP) file

eImageFile

Raster image file; BMP, GIF, JPG, PNG, ...

eMaterialTextureFile

Texture material file

eNoType

File of unknown type

ePDFUnderlay

PDF underlay file

ePfbAltFontFile

PFB alternate font file

ePfbFontFile

PFB font file

ePhotometricWebFile

Photometric Web file

ePlotCfgFile

Plotter Configuration file

ePlotStyleTableFile

Plot Style Table file

eSheetSetFile

Sheet Set (DST) file

eSheetSetSupportFile

Support file used by a Sheet Set file

eShxAltFontFile

SHX alternate font file

eShxFontFile

SHX font file

eTtfAltFontFile

TTF alternate font file

eTtfFontFile

TTF font file

eUserAddedFile

File added manually to the transmittal set by the user

eXrefAttachFile

Xref file attached as an attachment

eXrefFile

Xref file

eXrefOverlayFile

Xref file attached as an overlay

Release Information

Releases: AutoCAD 2004 and later

Examples

VB.NET:

None available

C#

None available