Gets a Links collection based on link template, link key values, and (optionally) link type.
VBA / VB.NET
RetVal = object.GetLinksByKey(LinkTemplate, KeyValues [, LinkTypes] [, Document])
Type: DbConnect
The object or objects this method applies to.
Type: LinkTemplate, or String identifying a link template; input-only
Specifies the link template whose links are returned.
Type: KeyValues; input-only
The KeyValues collection containing the key values to search for.
Type: Integer; input-only; optional
Specifies the type of links to return. You can specify any combination of the following link types:
If no value is specified, all label links are returned.
Type: AcadDocument; input-only; optional
This argument is ignored if a LabelTemplate object is passed as the first argument. If this argument is not specified, the document object is identified as follows:
Type: Links
The Links collection for the specified keys.