IsCanceled Method (ActiveX/ATO)

Triggered when a request to cancel the processing of files for the transmittal set is received.

Supported platforms: Windows only

Namespace: TRANSMITTALLib

Assembly: AcETransmit19.tlb

Signature

VB.NET:

Friend Class custom_class_name
    Implements TransmittalProgressHandler

    Public Sub isCanceled(ByRef cancelled As Integer) _
        Implements ITransmittalProgressHandler.isCanceled
        ...
    End Sub

End Class

C#:

internal class custom_class_name : TransmittalProgressHandler
{
    public void isCanceled(out int cancelled)
    {
        ...
    }
}
custom_class_name

The name of the custom class.

cancelled

Access: Output-only

Type: Integer

  • 0 (False): Processing should not be cancelled
  • 1 (True): Processing should be cancelled

Return Value (RetVal)

No return value.

Remarks

No additional remarks.

Release Information

Releases: AutoCAD 2005 and later

Examples

VB.NET:

Friend Class MyProgressHandler
    Implements TransmittalProgressHandler

    Public Sub isCanceled(ByRef cancelled As Integer) _
        Implements TRANSMITTALLib.ITransmittalProgressHandler.isCanceled

        Application.DocumentManager.MdiActiveDocument.Editor. _
            WriteMessage(Environment.NewLine & "Transmital process cancelled status")
    End Sub
End Class

C#:

internal class MyProgressHandler : TransmittalProgressHandler
{
    public void isCanceled(out int cancelled)
    {
        Application.DocumentManager.MdiActiveDocument.Editor.
            WriteMessage(Environment.NewLine + "Transmital process cancelled status");

        cancelled = 0;
    }
}