GetTransmittalInfoInterface Method (ActiveX/ATO)

Returns the information object used to store the settings that are used to create a transmittal package.

Supported platforms: Windows only

Namespace: TRANSMITTALLib

Assembly: AcETransmit19.tlb

Signature

VB.NET:

RetVal = object.getTransmittalInfoInterface()

C#:

RetVal = object.getTransmittalInfoInterface();
object

Type: TransmittalOperation object

The object this method applies to.

Return Value (RetVal)

Type: TransmittalInfo object

The information object of the transmittal set.

Remarks

No additional remarks.

Release Information

Releases: AutoCAD 2005 and later

Examples

VB.NET:

' Custom command to create a transmittal package with a drawing file
<CommandMethod("eTransmitDWGFile")> _
Public Shared Sub eTransmitDWGFile()

    ' Create a transmittal operation
    Dim tro As TransmittalOperation = New TransmittalOperation()

    ' Setup the transmittal behavior
    Dim ti As TransmittalInfo = _
        TransInfo(tro.getTransmittalInfoInterface(), "C:\Users\Public\TransmittalAPITest\")

    ' Add a DWG file
    Dim tf As TransmittalFile = Nothing
    tro.addDrawingFile("C:\AutoCAD\Sample\Sheet Sets\Architectural\A-02.dwg", tf)

    ' Create the transmittal package
    ' Files are copied and resaved to the path specified by the destinationRoot property
    ' and the other settings of the TransmittalInfo object.
    tro.createTransmittalPackage()
End Sub

C#:

// Custom command to create a transmittal package with a drawing file
[CommandMethod("eTransmitDWGFile")]
public static void eTransmitDWGFile()
{
    // Create a transmittal operation
    TransmittalOperation tro = new TransmittalOperation();

    // Setup the transmittal behavior
    TransmittalInfo ti =
        TransInfo(tro.getTransmittalInfoInterface(), "C:\\Users\\Public\\TransmittalAPITest\\");

    // Add a DWG file
    TransmittalFile tf = null;
    tro.addDrawingFile("C:\\AutoCAD\\Sample\\Sheet Sets\\Architectural\\A-02.dwg", out tf);

    // Create the transmittal package
    // Files are copied and resaved to the path specified by the destinationRoot property
    // and the other settings of the TransmittalInfo object.
    tro.createTransmittalPackage();
}