ApplyFix Method (ActiveX/CSP)

Applies the property values of a fix object to an error.

Supported platforms: Windows only

Namespace: AcStMgr

Assembly: AcStMgr.tlb

Signature

VB.NET:

object.ApplyFix([pFix], pFailedReason)

C#:

object.ApplyFix([pFix], out pFailedReason);
object

Type: AcStError object

The object this method applies to.

pFix

Access: Input-only

Type: AcStFix object

The fix object which should be used to correct the properties of an object that does not match the established CAD standards.

pFailedReason

Access: Output-only

Type: String

The error value that represents the reason why the fix failed. The value returned should align with one of those in the AcStResultStatus enumeration.

The default return value is "0".

Return Value (RetVal)

No return value.

Remarks

No additional remarks.

Release Information

Releases: AutoCAD 2004 and later

Examples

VB.NET:

Not available

C#:

Not available