PreSheetSetProcessing Method (ActiveX/ATO)

Triggered before the processing of a sheet set.

Supported platforms: Windows only

Namespace: TRANSMITTALLib

Assembly: AcETransmit19.tlb

Signature

VB.NET:

Friend Class custom_class_name
    Implements ITransmittalSheetSetNotification

    Public Sub preSheetSetProcessing(pISheetSet As Object, _
                                     pFile As TransmittalFile, _
                                     pTransmit As TransmittalOperation) _
        Implements ITransmittalSheetSetNotification.preSheetSetProcessing

        ...
    End Sub

End Class

C#:

internal class custom_class_name : ITransmittalSheetSetNotification
{
     public void preSheetSetProcessing(object pISheetSet, 
                                       TransmittalFile pFile,
                                       TransmittalOperation pTransmit)
     {
        ...
     }
}
custom_class_name

The name of the custom class.

pISheetSet

Access: Input-only

Type: Object (Unknown)

Pointer to the AcSmSheetSet object that will be processed.

pFile

Access: Input-only

Type: TransmittalFile object

Pointer to the TransmittalFile object that represents the drawing file in the sheet set that will be processed.

pTransmit

Access: Input-only

Type: TransmittalOperation object

Pointer to the TransmittalOperation object that represents the transmittal set in which the drawing file was added.

Return Value (RetVal)

No return value.

Remarks

No additional remarks.

Release Information

Releases: AutoCAD 2005 and later

Examples

VB.NET:

' Custom class used to monitor the processing of a sheet set
Friend Class MyTransSSMNotifier
    Implements ITransmittalSheetSetNotification

    Public Sub preSheetSetProcessing(pISheetSet As Object, _
                                     pFile As TRANSMITTALLib.TransmittalFile, _
                                     pTransmit As TRANSMITTALLib.TransmittalOperation) _
        Implements TRANSMITTALLib.ITransmittalSheetSetNotification.preSheetSetProcessing

        Application.DocumentManager.MdiActiveDocument.Editor. _
            WriteMessage(Environment.NewLine & "Sheet Set preprocessing: " & pFile.sourcePath)
    End Sub
End Class

C#:

// Custom class used to monitor the processing of a sheet set
internal class MyTransSSMNotifier : ITransmittalSheetSetNotification
{
    public void preSheetSetProcessing(object pISheetSet, TRANSMITTALLib.TransmittalFile pFile,
                                      TRANSMITTALLib.TransmittalOperation pTransmit)
    {
        Application.DocumentManager.MdiActiveDocument.Editor.
            WriteMessage(Environment.NewLine + "Sheet Set preprocessing: " + pFile.sourcePath);
    }
}