To Create a New Project for a CAD Standards Plug-in (ActiveX/CSP)

A plug-in cannot be loaded directly into the AutoCAD program, but you need to make sure specific properties are enabled so it can be loaded into the CAD Standards framework that is part of the AutoCAD program or the stand-alone Batch Standards Checker. Each plug-in project must be based on the Class Library template. After new project is created, you must reference the AutoCAD <release> Type and the and Autodesk Standards Manager Type libraries.

  1. Start Microsoft Visual Studio.
  2. In Microsoft Visual Studio, on the menu bar, click File menu New Project or File menu New Project.
  3. In the New Project dialog box, expand Installed Templates and do one of the following:
    • Visual Basic - Click Visual Basic and then select Class Library.
    • Visual C# - Click Visual C# and then select Class Library.
    • Visual C++ - Expand C++, click CLR and then select Class Library.
  4. In the Name field, enter a name for the project and click OK.
  5. On the menu bar, click Project menu <project name> Properties.
  6. In the Properties dialog box, References tab, click Add.
  7. In the Add Reference dialog box, Browse tab, browse to and <drive>:\ObjectARX <version>\inc-<platform>.

    <drive> and <version> represents the location in which the ObjectARX SDK is installed. <platform> should be replaced with win32 or x64 based on the target platform.

  8. Press and hold Ctrl, and then select AcStMgr.dll (which needs to be created from the AcStMgr.tlb file) and axdb<version><language>.tlb. Click OK.
    Note: <version> and <language> represent the version and language of the ObjectDBX library to reference. For example, axdb20enu.tlb represents the version of the library that is supported by the English release of Autodesk AutoCAD 2015 and AutoCAD 2016.
  9. Click Add again and click the COM tab..
  10. On the COM tab, scroll to and select Microsoft XML Type library (Microsoft XML, v6.0). Click OK.
  11. Click the Application tab.
  12. On the Application tab, click Assembly Information.
  13. In the Assembly Information dialog box, click Make Assembly COM-Visible (should now be checked) and click OK.