GetDependent Method (ActiveX/ATO)

Returns the dependent of a file at the specified index.

Supported platforms: Windows only

Namespace: TRANSMITTALLib

Assembly: AcETransmit19.tlb

Signature

VB.NET:

RetVal = object.getDependent(nIndex)

C#:

RetVal = object.getDependent(nIndex);
object

Type: TransmittalFile object

The object this method applies to.

nIndex

Access: Input-only

Type: Long

Index of the dependent file to retrieve.

Return Value (RetVal)

Type: TransmittalFile object

The dependent file at the specified index.

Remarks

No additional remarks.

Release Information

Releases: AutoCAD 2005 and later

Examples

VB.NET:

' Custom command that displays information about a file
<CommandMethod("FileInfo")> _
Public Shared Sub FileInfo()
    ' Create a transmittal operation
    Dim tro As TransmittalOperation = New TransmittalOperation()

    ' Setup the transmittal behavior
    Dim ti As TransmittalInfo = TransInfo(tro.getTransmittalInfoInterface(), _
                                          "C:\Users\Public\TransmittalAPITest\")

    ' Define file to add to the transmittal
    Dim tf As TransmittalFile = Nothing
    Dim dwgFile As String = "C:\AutoCAD\Sample\Sheet Sets\Architectural\A-01.dwg"

    ' Add file to transmittal and parse its information
    If tro.addDrawingFile(dwgFile, tf) = AddFileReturnVal.eFileAdded Then
        ' Get the current editor
        Dim acEditor As Editor = Application.DocumentManager.MdiActiveDocument.Editor

        ' Output information about the file in the transmittal set
        ' Source and full target path to the file
        acEditor.WriteMessage(Environment.NewLine & "Source Path: " & tf.sourcePath)
        acEditor.WriteMessage(Environment.NewLine & "Full Path: " & tf.fullPathForTarget)
        acEditor.WriteMessage(Environment.NewLine & "Target SubPath: " & tf.targetSubPath)

        ' See if the file is a drawing
        If System.IO.Path.GetExtension(tf.sourcePath).ToUpper() = ".DWG" Then
            ' Number of dependents and dependees
            acEditor.WriteMessage(Environment.NewLine & "# of Dependents: " & tf.numberOfDependents.ToString())
            acEditor.WriteMessage(Environment.NewLine & "# of Dependees: " & tf.numberOfDependees.ToString())

            ' Get the first dependent of the drawing
            If tf.numberOfDependents > 0 Then
                acEditor.WriteMessage(Environment.NewLine & "Name of First Dependent: " & tf.getDependent(0).sourcePath)
            Else
                acEditor.WriteMessage(Environment.NewLine & "No dependents")
            End If

            ' Get the first dependee of the drawing
            If tf.numberOfDependees > 0 Then
                acEditor.WriteMessage(Environment.NewLine & "Name of First Dependee: " & tf.getDependee(0).sourcePath)
            Else
                acEditor.WriteMessage(Environment.NewLine & "No dependees")
            End If
        End If

        ' Output file system information about the file
        acEditor.WriteMessage(Environment.NewLine & "File Exists: " & tf.fileExists.ToString())
        acEditor.WriteMessage(Environment.NewLine & "File Size: " & tf.fileSize.ToString())
        acEditor.WriteMessage(Environment.NewLine & "File Type: " & tf.FileType.ToString())
        acEditor.WriteMessage(Environment.NewLine & "Include in transmittal: " & tf.includeInTransmittal.ToString())
        acEditor.WriteMessage(Environment.NewLine & "Date/Time: " & tf.lastModifiedTime.ToLongDateString() & "  " &
                                                                    tf.lastModifiedTime.ToLongTimeString())
        acEditor.WriteMessage(Environment.NewLine & "Type: " & tf.type.ToString())
        acEditor.WriteMessage(Environment.NewLine & "Version: " & tf.version.ToString())
    End If
End Sub

C#:

// Custom command that displays information about a file
[CommandMethod("FileInfo")]
public static void FileInfo()
{
    // Create a transmittal operation
    TransmittalOperation tro = new TransmittalOperation();

    // Setup the transmittal behavior
    TransmittalInfo ti = TransInfo(tro.getTransmittalInfoInterface(),
                                   @"C:\Users\Public\TransmittalAPITest\");

    // Define file to add to the transmittal
    TransmittalFile tf = null;
    string dwgFile = @"C:\AutoCAD\Sample\Sheet Sets\Architectural\A-01.dwg";

    // Add file to transmittal and parse its information
    if (tro.addDrawingFile(dwgFile, out tf) == AddFileReturnVal.eFileAdded)
    {
        // Get the current editor
        Editor acEditor = Application.DocumentManager.MdiActiveDocument.Editor;

        // Output information about the root file of the transmittal set
        // Source and full target path to the file
        acEditor.WriteMessage(Environment.NewLine + "Source Path: " + tf.sourcePath);
        acEditor.WriteMessage(Environment.NewLine + "Full Path: " + tf.fullPathForTarget);
        acEditor.WriteMessage(Environment.NewLine + "Target SubPath: " + tf.targetSubPath);

        // See if the root file is a drawing
        if (Path.GetExtension(tf.sourcePath).ToUpper() == ".DWG")
        {
            // Number of dependents and dependees
            acEditor.WriteMessage(Environment.NewLine + "# of Dependents: " + tf.numberOfDependents.ToString());
            acEditor.WriteMessage(Environment.NewLine + "# of Dependees: " + tf.numberOfDependees.ToString());

            // Get the first dependent of the drawing
            if(tf.numberOfDependents > 0)
            {
                acEditor.WriteMessage(Environment.NewLine + "Name of First Dependent: " + tf.getDependent(0).sourcePath);
            } else {
                acEditor.WriteMessage(Environment.NewLine + "No dependents");
            }

            // Get the first dependee of the drawing
            if (tf.numberOfDependees > 0)
            {
                acEditor.WriteMessage(Environment.NewLine + "Name of First Dependee: " + tf.getDependee(0).sourcePath);
            }
            else
            {
                acEditor.WriteMessage(Environment.NewLine + "No dependees");
            }
        }

        // Output file system information about the root file
        acEditor.WriteMessage(Environment.NewLine + "File Exists: " + tf.fileExists.ToString());
        acEditor.WriteMessage(Environment.NewLine + "File Size: " + tf.fileSize.ToString());
        acEditor.WriteMessage(Environment.NewLine + "File Type: " + tf.FileType.ToString());
        acEditor.WriteMessage(Environment.NewLine + "Include in transmittal: " + tf.includeInTransmittal.ToString());
        acEditor.WriteMessage(Environment.NewLine + "Date/Time: " + tf.lastModifiedTime.ToLongDateString() + "  " +
                                                                    tf.lastModifiedTime.ToLongTimeString());
        acEditor.WriteMessage(Environment.NewLine + "Type: " + tf.type.ToString());
        acEditor.WriteMessage(Environment.NewLine + "Version: " + tf.version.ToString());
    }
}