Triggered after the processing of a sheet set.
Supported platforms: Windows only
Namespace: TRANSMITTALLib
Assembly: AcETransmit19.tlb
VB.NET:
Friend Class custom_class_name Implements ITransmittalSheetSetNotification Public Sub postSheetSetProcessing(pISheetSet As Object, _ pFile As TransmittalFile, _ pTransmit As TransmittalOperation) _ Implements ITransmittalSheetSetNotification.postSheetSetProcessing ... End Sub End Class
C#:
internal class custom_class_name : ITransmittalSheetSetNotification { public void postSheetSetProcessing(object pISheetSet, TransmittalFile pFile, TransmittalOperation pTransmit) { ... } }
The name of the custom class.
Access: Input-only
Type: Object (Unknown)
Pointer to the AcSmSheetSet object that was processed.
Access: Input-only
Type: TransmittalFile object
Pointer to the TransmittalFile object that represents the drawing file in the sheet set that was processed.
Access: Input-only
Type: TransmittalOperation object
Pointer to the TransmittalOperation object that represents the transmittal set in which the drawing file was added.
No return value.
No additional remarks.
Releases: AutoCAD 2005 and later
VB.NET:
' Custom class used to monitor the processing of a sheet set Friend Class MyTransSSMNotifier Implements ITransmittalSheetSetNotification Public Sub postSheetSetProcessing(pISheetSet As Object, _ pFile As TRANSMITTALLib.TransmittalFile, _ pTransmit As TRANSMITTALLib.TransmittalOperation) _ Implements TRANSMITTALLib.ITransmittalSheetSetNotification.postSheetSetProcessing Application.DocumentManager.MdiActiveDocument.Editor. _ WriteMessage(Environment.NewLine & "Sheet Set post processing: " & pFile.sourcePath) End Sub End Class
C#:
// Custom class used to monitor the processing of a sheet set internal class MyTransSSMNotifier : ITransmittalSheetSetNotification { public void postSheetSetProcessing(object pISheetSet, TRANSMITTALLib.TransmittalFile pFile, TRANSMITTALLib.TransmittalOperation pTransmit) { Application.DocumentManager.MdiActiveDocument.Editor. WriteMessage(Environment.NewLine + "Sheet Set post processing: " + pFile.sourcePath); } }