Creates a transmittal package based on the files and settings of a transmittal set.
Supported platforms: Windows only
Namespace: TRANSMITTALLib
Assembly: AcETransmit19.tlb
VB.NET:
object.createTransmittalPackage()
C#:
object.createTransmittalPackage();
Type: TransmittalOperation object
The object this method applies to.
No return value.
No additional remarks.
Releases: AutoCAD 2005 and later
VB.NET:
' Custom command to create a transmittal package with a drawing file <CommandMethod("eTransmitDWGFile")> _ Public Shared Sub eTransmitDWGFile() ' Create a transmittal operation Dim tro As TransmittalOperation = New TransmittalOperation() ' Setup the transmittal behavior Dim ti As TransmittalInfo = _ TransInfo(tro.getTransmittalInfoInterface(), "C:\Users\Public\TransmittalAPITest\") ' Add a DWG file Dim tf As TransmittalFile = Nothing tro.addDrawingFile("C:\AutoCAD\Sample\Sheet Sets\Architectural\A-02.dwg", tf) ' Create the transmittal package ' Files are copied and resaved to the path specified by the destinationRoot property ' and the other settings of the TransmittalInfo object. tro.createTransmittalPackage() End Sub
C#:
// Custom command to create a transmittal package with a drawing file [CommandMethod("eTransmitDWGFile")] public static void eTransmitDWGFile() { // Create a transmittal operation TransmittalOperation tro = new TransmittalOperation(); // Setup the transmittal behavior TransmittalInfo ti = TransInfo(tro.getTransmittalInfoInterface(), "C:\\Users\\Public\\TransmittalAPITest\\"); // Add a DWG file TransmittalFile tf = null; tro.addDrawingFile("C:\\AutoCAD\\Sample\\Sheet Sets\\Architectural\\A-02.dwg", out tf); // Create the transmittal package // Files are copied and resaved to the path specified by the destinationRoot property // and the other settings of the TransmittalInfo object. tro.createTransmittalPackage(); }