AddToObjectIdList Method (ActiveX/CSP)

Builds an array of object IDs that represent the objects which were modified and need to be checked.

For internal use only.

Supported platforms: Windows only

Namespace: AcStMgr

Assembly: AcStMgr.tlb

Signature

VB.NET:

object.AddToObjectIdList(objId, pClass, flags)

C#:

object.AddToObjectIdList(objId, pClass, flags);
object

Type: AcStErrorIterator object

The object this method applies to.

objId

Access: Input-only

Type: LongPtr (Long)

The object ID of the object to add to the array.

pClass

Access: Input-only

Type: LongPtr (Long)

The pointer of the object to add to the array.

The object should derive from the AcRxClass, AcDbObject, or AcadObject type.

flags

Access: Input-only

Type: Long

The context in which the AutoCAD program is currently executing.

  • 0 - No script or program is executing.
  • 1 - A script or program is executing.

Return Value (RetVal)

No return value.

Remarks

No additional remarks.

Release Information

Releases: AutoCAD 2004 and later

Examples

VB.NET:

Not available

C#:

Not available