getenv (AutoLISP)

Returns the string value assigned to a system environment variable

Supported Platforms: Windows and Mac OS

Signature

(getenv variable-name)
variable-name

Type: String

A string specifying the name of the variable to be read. Environment variable names must be spelled and cased exactly as they are stored in the system registry.

Return Values

Type: String or nil

A string representing the value assigned to the specified system variable. If the variable does not exist, getenv returns nil.

Examples

Assume the system environment variable ACAD is set to /acad/support and there is no variable named NOSUCH.

(getenv "ACAD")
"/acad/support"

(getenv "NOSUCH")
nil

Assume that the MaxArray environment variable is set to 10000:

(getenv "MaxArray")
"10000"