Returns a list of the currently defined symbols
Supported Platforms: Windows and Mac OS
(atoms-family format [symlist])
Type: Integer
An integer value of 0 or 1 that determines the format in which atoms-family returns the symbol names:
0 -- Return the symbol names as a list
1 -- Return the symbol names as a list of strings
Type: List
A list of strings that specify the symbol names you want atoms-family to search for.
Type: List
A list of symbols. If you specify symlist, then atoms-family returns the specified symbols that are currently defined, and returns nil for those symbols that are not defined.
(atoms-family 0) (BNS_PRE_SEL FITSTR2LEN C:AI_SPHERE ALERT DEFUN C:BEXTEND REM_GROUP B_RESTORE_SYSVARS BNS_CMD_EXIT LISPED FNSPLITL...)
The following code verifies that the symbols CAR, CDR, and XYZ are defined, and returns the list as strings:
(atoms-family 1 '("CAR" "CDR" "XYZ")) ("CAR" "CDR" nil)
The return value shows that the symbol XYZ is not defined.