quote (AutoLISP)

Returns an expression without evaluating it

Supported Platforms: Windows and Mac OS

Signature

(quote expr)
expr

Type: Integer, Real, String, List, Symbol, File, Subroutine, Ename (entity name), T, or nil

An AutoLISP expression.

Return Values

Type: Integer, Real, String, List, Symbol, File, Subroutine, Ename (entity name), T, or nil

The expr argument.

Examples

(quote a)
A

The previous expression can also be written as 'a. For example:

!'a
A

(quote (a b))
(A B)