getcname (AutoLISP)

Retrieves the localized or English name of an AutoCAD command

Supported Platforms: Windows and Mac OS

Signature

(getcname cname)
cname

Type: String

The localized or underscored English command name; must be 64 characters or less in length.

Return Values

If cname is not preceded by an underscore (assumed to be the localized command name), getcname returns the underscored English command name. If cname is preceded by an underscore, getcname returns the localized command name. This function returns nil if cname is not a valid command name.

Examples

In a French version of AutoCAD, the following is True.

(getcname "ETIRER")
"_STRETCH"
 
(getcname "_STRETCH")
"ETIRER"