vlax-curve-getClosestPointToProjection (AutoLISP/ActiveX)

Returns the closest point (in WCS) on a curve after projecting the curve onto a plane

Supported Platforms: Windows only

Signature

(vlax-curve-getClosestPointToProjection curve-obj givenPnt normal [extend])
curve-obj

Type: VLA-object

The object to be measured.

givenPnt

Type: List

A point (in WCS) for which to find the nearest point on the curve.

normal

Type: List

A normal vector (in WCS) for the plane to project onto.

extend

Type: T

If specified and not nil, vlax-curve-getClosestPointToProjection extends the curve when searching for the nearest point.

Return Values

Type: List or nil

A 3D point representing a point on the curve, if successful; otherwise nil.

Remarks

vlax-curve-getClosestPointToProjection projects the curve onto the plane defined by the givenPnt and normal, and then calculates the nearest point on that projected curve to givenPnt. The resulting point is then projected back onto the original curve, and vlax-curve-getClosestPointToProjection returns that projected point.

Example

N/A