vl-member-if-not (AutoLISP)

Determines if the predicate is nil for one of the list members

Supported Platforms: Windows and Mac OS

Signature

(vl-member-if-not predicate-function lst)
predicate-function

Type: Subroutine or Symbol

The test function. This can be any function that accepts a single argument and returns T for any user-specified condition. The predicate-function value can take one of the following forms:

  • A symbol (function name)
  • '(LAMBDA (A1 A2) ...)
  • (FUNCTION (LAMBDA (A1 A2) ...))
lst

Type: List

A list to be tested.

Return Values

Type: List or nil

A list, starting with the first element that fails the test and containing all elements following this in the original argument. If none of the elements fails the test condition, vl-member-if-not returns nil.

Remarks

The vl-member-if-not function passes each element in lst to the function specified in predicate-function. If the function returns nil, vl-member-if-not returns the rest of the list in the same manner as the member function.

Examples

(vl-member-if-not 'atom '(1 "Str" (0 . "line") nil t))
((0 . "line") nil T)