vl-consp (AutoLISP)

Determines whether or not a list is nil

Supported Platforms: Windows and Mac OS

Signature

(vl-consp list-variable)
list-variable

Type: Integer, Real, String, List, Subroutine, Ename (entity name), T, nil, or catch-all-apply-error

A list.

Return Values

Type: T or nil

T, if list-variable is a list and is not nil; otherwise nil.

Remarks

The vl-consp function determines whether a variable contains a valid list definition.

Examples

(vl-consp nil)
nil

(vl-consp t)
nil

(vl-consp (cons 0 "LINE"))
T