entmakex (AutoLISP)

Makes a new object or entity, gives it a handle and entity name (but does not assign an owner), and then returns the new entity name

Supported Platforms: Windows and Mac OS

Signature

(entmakex [elist])
elist

Type: List

Entity definition data in a format similar to that returned by the entget function. The elist argument must contain all of the information necessary to define the entity. If any required definition data is omitted, entmakex returns nil and the entity is rejected. If you omit optional definition data (such as the layer), entmakex uses the default value.

Return Values

Type: Ename (entity name)

If successful, entmakex returns the name of the entity created. If entmakex is unable to create the entity, the function returns nil.

Remarks

The entmakex function can define both graphical and nongraphical entities.

Examples

(entmakex '((0 . "CIRCLE") (62 . 1) (10 4.0 3.0 0.0) (40 . 1.0)))
<Entity name: 1d45558>
Caution: Objects and entities without owners are not written out to DWG or DXF files. Be sure to set an owner at some point after using entmakex. For example, you can use dictadd to set a dictionary to own an object.