Predefines command names to load an associated AutoLISP file
Supported Platforms: Windows and Mac OS
(autoload filename cmdlist)
Type: String
AutoLISP file to be loaded when one of the commands defined by the cmdlist argument is entered at the Command prompt. You can omit the path from the filename, AutoCAD looks for the file in the support file search path. The extension from the filename can also be omitted; .lsp or .fas, or .vlx (Windows only).
Type: List
A list of strings.
Type: nil
Always returns nil.
If you associate a command with filename and that command is not defined in the specified file, AutoCAD alerts you with an error message when you enter the command.
The first time a user enters a command specified in cmdlist, AutoCAD loads the application specified in filename, then continues the command.
The following causes AutoCAD to load the bonusapp.lsp file the first time the APP1, APP2, or APP3 commands are entered at the Command prompt:
(autoload "BONUSAPP" '("APP1" "APP2" "APP3"))