expand (AutoLISP)

Allocates additional memory for AutoLISP

Supported Platforms: Windows and Mac OS

Signature

(expand n-expand)
n-expand

Type: Integer

An number indicating the amount of additional memory to be allocated. Memory is allocated as follows:

  • n-alloc free symbols
  • n-alloc free strings
  • n-alloc free usubrs
  • n-alloc free reals
  • n-alloc * n-expand cons cells

where n-alloc is the current segment size.

Return Values

Type: Integer

A number indicating the number of free conses divided by n-alloc.

Examples

Set the segment size to 100:

(alloc 100)
1000

Allocate memory for two additional segments:

(expand 2)
82

This ensures that AutoLISP now has memory available for at least 200 additional symbols, strings, usubrs and reals each, and 8200 free conses.