During the development cycle of an AutoLISP program, the AutoLISP developer performs a number of operations that are not available within the AutoCAD software.
Note: The Visual LISP IDE is available on Windows only.
Some of these operations—like text editing—are available with other software tools. Others, such as full AutoLISP source-level debugging, are introduced only with Visual LISP. In Visual LISP, you perform most of the necessary operations related to developing AutoLISP programs inside a single environment. This includes text editing, program debugging, and interaction with AutoCAD and other applications.
Text editing and debugging and performed through the various windows and menus that are distinct from AutoCAD, but Visual LISP does not run independently of AutoCAD. Whenever you work in Visual LISP, AutoCAD must also be running. When you run AutoLISP programs from the Visual LISP IDE, you will usually need to interact with the AutoCAD drawing window or Command prompt.
The following are components of the Visual LISP integrated development environment:
- Source Debugger designed specifically for AutoLISP, supports stepping through AutoLISP source code in one window while simultaneously displaying the results of code execution in the AutoCAD software.
- Text File Editor uses AutoLISP and DCL color coding, as well as other AutoLISP syntax support features.
- AutoLISP Formatter restructures programs into an easily readable format.
- Comprehensive Inspect and Watch features provide convenient access to variable and expression values for data structure browsing and modification. These features may be used to explore AutoLISP data and AutoCAD drawing entities.
- Context-sensitive Help provides information for AutoLISP functions and a powerful Apropos feature for symbol name search.
- Syntax Checker recognizes erroneous AutoLISP constructs and improper arguments in calls to built-in functions.
- File Compiler improves the execution speed and provides a secure and efficient delivery platform.
- Project Management system makes it easy to maintain multiple-file applications.
- Compiled AutoLISP files are packaged into a single module.
- Desktop Save and Restore capabilities preserve and reuse the windowing environment from any Visual LISP session.
- Intelligent Console window introduces a new level of convenience and efficiency for AutoLISP developers. The basic functions of the Console correspond to the AutoCAD Text Screen functions and provide a number of interactive features, such as history scrolling and full-input line editing.