Returns the current value of an entity’s property
Supported Platforms: Windows and Mac OS
(getpropertyvalue ename propertyname [or collectionName index name])
Type: Ename (entity name)
Name of the entity being queried. The ename can refer to either a graphical or a nongraphical entity.
Type: String
Name of the property being queried. For a list of all the valid property names of a given object, use dumpallproperties.
Type: String
If the object is a collection object, the Collection name is passed here.
Type: Integer
The collection index being queried.
Type: String
The name of the property within the collection being queried.
Type: Integer, Real, String, List, T, or nil
The value of the entity’s property.
The following example demonstrates how to get the current radius value of a circle.
(command "_circle" "2,2" 2) nil (getpropertyvalue (entlast) "radius") 2.0