fix (AutoLISP)

Returns the conversion of a real number into the nearest smaller integer

Supported Platforms: Windows and Mac OS

Signature

(fix number)
number

Type: Integer or Real

A numeric value.

Return Values

Type: Integer

The integer derived from number.

If number is larger than the largest possible integer (+2,147,483,647 or -2,147,483,648 on a 32-bit platform), fix returns a truncated real (although integers transferred between AutoLISP and AutoCAD are restricted to 16-bit values).

Remarks

The fixfunction truncates number to the nearest integer by discarding the fractional portion.

Examples

(fix 3)
3

(fix 3.7)
3