vl-get-resource (AutoLISP/Visual LISP IDE)

Returns the text stored in a .txt file packaged in a VLX

Supported Platforms: Windows only

Signature

(vl-get-resource text-file)
text-file

Type: String

Name of a .txt file packaged with the VLX. Do not include the .txt extension when specifying the file name.

Return Values

Type: String

A textual value containing the text in text-file.

Examples

Assume the getres.vlx file contains a LISP program defining a function named print-readme, and a text file named readme.txt. The print-readme function is defined as follows:

(defun print-readme ()
   (princ (vl-get-resource "readme"))
   (princ)
)

After loading getres.vlx, invoke print-readme:

(print-readme)
Product Readme text
Product Readme text 2