vl-list* (AutoLISP)

Constructs and returns a list

Supported Platforms: Windows and Mac OS

Signature

(vl-list* object [object ...])
object

Type: Integer, Real, String, List, File, Symbol, Ename (entity name), T, or nil

Any LISP object.

Return Values

The vl-list* function is similar to list, but it will place the last object in the final cdr of the result list. If the last argument to vl-list* is an atom, the result is a dotted list. If the last argument is a list, its elements are appended to all previous arguments added to the constructed list. The possible return values from vl-list* are

Examples

(vl-list* 1)
1

(vl-list* 0 "text")
(0 . "TEXT")

(vl-list* 1 2 3)
(1 2 . 3)

(vl-list* 1 2 '(3 4))
(1 2 3 4)