rotate3d (AutoLISP/External Function)

Rotates an object about an arbitrary 3D axis

Supported Platforms: Windows and Mac OS

Prerequisites: The Geom3d ObjectARX application must be loaded before the function can be called, (arxload "geom3d").

Signature

(rotate3d args ...)
args

Type: String, List, Ename (entity name), or nil

The order, number, and type of arguments for the rotate3d function are the same as if you were using the AutoCAD ROTATE3D command.

A null response (a user pressing Enter) can be indicated by specifying nil or an empty string ("").

Return Values

Type: T or nil

If successful, rotate3d returns T; otherwise it returns nil.

Examples

The following example rotates the selected objects 30 degrees about the axis specified by points p1 and p2.

(setq ss (ssget))
(setq p1 (getpoint "\nPoint1: "))
(setq p2 (getpoint "\nPoint2: "))
(rotate3d ss p1 p2 30)

AutoLISP support for the rotate3d function is implemented with the use of the SAGET library.