~ (bitwise NOT) (AutoLISP)

Returns the bitwise NOT (1's complement) of the argument

Supported Platforms: Windows and Mac OS

Signature

(~ int)
int

Type: Integer

A positive or negative integer value.

Return Values

Type: Integer

The bitwise NOT (1's complement) of the argument.

Examples

(~ 3)
-4

(~ 100)
-101

(~ -4)
3