align (AutoLISP/External Function)

Translates and rotates objects, allowing them to be aligned with other objects

Supported Platforms: Windows and Mac OS

Prerequisites: The Geom3d ObjectARX application must be loaded before the function can be called, (arxload "geom3d").

Signature

(align args ...)
args

Type: String, List, Ename (entity name), or nil

The order, number, and type of arguments for the align function are the same as if you were using the AutoCAD ALIGN command.

A null response (a user pressing Enter) can be indicated by specifying nil or an empty string ("").

Return Values

Type: T or nil

If successful, align returns T; otherwise it returns nil.

Examples

The following example specifies two pairs of source and destination points, which perform a 2D move and does not scale the objects based on alignment points:

(setq ss (ssget))
(setq s1 (getpoint "\nSource1: "))
(setq d1 (getpoint s1 "\nDestination1: "))
(setq s2 (getpoint "\nSource2: "))
(setq d2 (getpoint s2 "\nDestination2: "))
(align ss s1 d1 s2 d2 "" "n")
T