getvar (AutoLISP)

Retrieves the value of an AutoCAD system variable

Supported Platforms: Windows and Mac OS

Signature

(getvar varname)
varname

Type: String

Names of a system variable.

See the product's Help system for a list of current AutoCAD system variables.

Return Values

Type: Integer, Real, String, List, or nil

The value of the system variable; otherwise nil, if varname is not a valid system variable.

Examples

Get the current value of the fillet radius:

(getvar 'FILLETRAD)
0.25