Lists all files in a given directory
Supported Platforms: Windows and Mac OS
(vl-directory-files [directory pattern directories])
Type: String
Directory name to collect files for; if nil or absent, vl-directory-files uses the current directory.
Type: String
Valid wildcard pattern for the file name; if nil or absent, vl-directory-files assumes “*.*”
Type: Integer
Value that indicates whether the returned list should include directory names. Specify one of the following:
-1 -- List directories only
0 -- List files and directories (the default)
1 -- List files only
Type: List or nil
A list of file and path names; otherwise nil if no files match the specified pattern.
(vl-directory-files "c:/acadwin" "acad*.exe") ("ACAD.EXE" "ACADAPP.EXE" "ACADL.EXE" "ACADPS.EXE") (vl-directory-files "e:/acadwin" nil -1) ("." ".." "SUPPORT" "SAMPLE" "ADS" "FONTS" "IGESFONT" "SOURCE" "ASE") (vl-directory-files "E:/acad" nil -1) ("." ".." "WIN" "COM" "DOS")
(vl-directory-files "/myutilities/lsp" "*.lsp") ("utilities.lsp" "blk-insert.lsp") (vl-directory-files "/myutilities" nil -1) ("." ".." ".DS_Store" "Help" "Lsp" "Support")