Forces the display of the next command's dialog box
Supported Platforms: Windows and Mac OS
(initdia [dialogflag])
Type: Integer
A numeric value. If this argument is not present or is present and nonzero, the next use (and next use only) of a command will display that command's dialog box rather than its command line prompts.
If dialogflag is zero, any previous call to this function is cleared, restoring the default behavior of presenting the command line interface.
Type: nil
Always returns nil.
Currently, the following commands make use of the initdia function: ATTDEF, ATTEXT, BHATCH, BLOCK, COLOR, IMAGE, IMAGEADJUST, INSERT, LAYER, LINETYPE, MTEXT, PLOT, RENAME, STYLE, TOOLBAR, and VIEW.
Issue the PLOT command without calling initdia first:
Command: (command "._plot")
plot
Enter a layout name <Model>: nil
Enter a layout name <Model>:
AutoCAD prompts for user input in the command window.
Use the following sequence of function calls to make AutoCAD display the Plot dialog box:
(initdia) (command "._plot")