regapp (AutoLISP)

Registers an application name with the current AutoCAD drawing in preparation for using extended object data

Supported Platforms: Windows and Mac OS

Signature

(regapp application)
application

Type: String

Application name. The name must be a valid symbol table name.

Return Values

Type: String

If an application of the same name has already been registered, this function returns nil; otherwise it returns the name of the application.

If registered successfully, the application name is entered into the APPID symbol table. This table maintains a list of the applications that are using extended data in the drawing.

Examples

(regapp "ADESK_4153322344")
"ADESK_4153322344"

(regapp "DESIGNER-v2.1-124753")
"DESIGNER-v2.1-124753"
Note: It is recommended that you pick a unique application name. One way of ensuring this is to adopt a naming scheme that uses the company or product name and a unique number (like your telephone number or the current date/time). The product version number can be included in the application name or stored by the application in a separate integer or real-number field; for example, (1040 2.1).