getcfg (AutoLISP)

Obsolete. Retrieves application data from the AppData section of the acad20xx.cfg file

Note: This function might be removed in a future release. As an alternative, use the vl-registry-read function to retrieve application data from the Windows Registry on Windows or property list file on Mac OS.

Supported Platforms: Windows and Mac OS

Signature

(getcfg cfgname)
cfgname

Type: String

Section name and parameter value to retrieve (maximum length of 496 characters).

The cfgname argument must be a string of the following form:

"AppData/application_name/section_name/.../param_name"

Return Values

Type: String or nil

Application data, if successful. If cfgname is not valid, getcfg returns nil.

Examples

Assuming the WallThk parameter in the AppData/ArchStuff section has a value of 8, the following command retrieves that value:

(getcfg "AppData/ArchStuff/WallThk")
"8"