eval (AutoLISP)

Returns the result of evaluating an AutoLISP expression

Supported Platforms: Windows and Mac OS

Signature

(eval expr)
expr

Type: Integer, Real, String, List, Symbol, Ename (entity name), T, or nil

The expression to be evaluated.

Return Values

Type: Integer, Real, String, List, Symbol, Ename (entity name), T, or nil

The result of the expression, after evaluation.

Examples

First, set some variables:

(setq a 123)
123

(setq b 'a)
A

Now evaluate some expressions:

(eval 4.0)
4.0

(eval (abs -10))
10

(eval a)
123

(eval b)
123