defun-q-list-ref (AutoLISP)

Displays the list structure of a function defined with defun-q

Supported Platforms: Windows and Mac OS

Signature

(defun-q-list-ref 'function )
function

Type: Symbol

A symbol naming the function.

Return Values

Type: List, Symbol, or nil

The list definition of the function; otherwise nil, if the argument is not a list.

Examples

Define a function using defun-q:

(defun-q my-startup (x) (print (list x)))
MY-STARTUP

Use defun-q-list-ref to display the list structure of my-startup:

(defun-q-list-ref 'my-startup)
((X) (PRINT (LIST X)))