autoarxload (AutoLISP)

Predefines command names to load an associated ObjectARX file

Supported Platforms: Windows and Mac OS

Signature

(autoarxload filename cmdlist)
filename

Type: String

ObjectARX file to be loaded when one of the commands defined by the cmdlist argument is entered at the Command prompt. You can omit the path from the filename, AutoCAD looks for the file in the support file search path. The extension from the filename can also be omitted; .arx (Windows) or .bundle (Mac OS).

cmdlist

Type: List

A list of strings.

Return Values

Type: nil

Always returns nil.

Remarks

The first time a user enters a command specified in cmdlist, AutoCAD loads the ObjectARX application specified in filename, then continues the command.

If you associate a command with filename and that command is not defined in the specified file, AutoCAD alerts you with an error message when you enter the command.

Important: Starting with AutoCAD 2014-based products, custom applications must work under secure mode; when the SECURELOAD system variable is set to 1 or 2. When operating under secure mode, the program is restricted to loading and executing files that contain code from trusted locations; trusted locations are specified by the TRUSTEDPATHS system variable.

Examples

The following code defines the C:APP1, C:APP2, and C:APP3 functions to load the bonusapp.arx or bonusapp.bundle file:

(autoarxload "BONUSAPP" '("APP1" "APP2" "APP3"))