angle (AutoLISP)

Returns an angle in radians of a line defined by two endpoints

Supported Platforms: Windows and Mac OS

Signature

(angle pt1 pt2)
pt1

Type: Integer or Real

An endpoint.

pt2

Type: Integer or Real

An endpoint.

Return Values

Type: Real

An angle, in radians.

The angle is measured from the X axis of the current construction plane, in radians, with angles increasing in the counterclockwise direction. If 3D points are supplied, they are projected onto the current construction plane.

Examples

(angle '(1.0 1.0) '(1.0 4.0))
1.5708

(angle '(5.0 1.33) '(2.4 1.33))
3.14159